Как мне установить пакеты без использования менеджера пакетов?

Я хотел бы знать, как установить .deb пакеты без использования менеджера пакетов, таких как dpkg. Можно ли это сделать? Какие файлы мне нужно редактировать? Или там уникальная процедура для каждого пакета?

+278
laure nmiller 17 июл. 2019 г., 17:56:44
26 ответов

Из Убунту Вики:

Ошибка программного обеспечения ошибка или ошибка в компьютерной программе, которая делает он не работать как надо. Это может быть как простой, как неспособности работать вообще, или так сложно, как слегка некорректно результат. Тем не менее, мы действительно хотим устранить ошибки в программном обеспечении, как они делают программы менее полезны.

Если вы встретите ошибку, вы должны сообщить об этом на Launchpad (или отметить себя в качестве пострадавших, если отчет уже существует, возможно, добавляя подробности в комментарии), так что разработчики в курсе проблемы и сможет должным образом исправить это для всех. Для получения информации о том, как это сделать, см. Как сообщить об ошибке? или эта документация Ubuntu страницы.

+967
Hau Le 03 февр. '09 в 4:24
  1. Установите Plex.
  2. Открыть терминал.
  3. Установить Самбу - судо apt-получить установку самбы.
  4. Из ~ Сделать компакт-диск ... Это приведет вас к /доме.
  5. Создать новый Плекс папку в /дом: судо команды mkdir Плекс
  6. Перейдите в новую папку: диск Плекс
  7. Создать новую папку в Плекс/: судо команды mkdir музыка
  8. Установить разрешения: судо команду chmod 777 * -Р
  9. Установить владельца, если требуется судо Чаун Плекс:Плекс -Р

Сделайте то же самое для других средств массовой информации, если требуется, не забывайте, если вы добавите новую медиа вы, возможно, потребуется задать разрешения владельца на это.

+962
DoctorRuss 30 янв. 2010 г., 14:31:45

Да, в то время как релиз Ubuntu продолжает поддерживаться, она будет получать обновленные версии Firefox.

Обратите внимание, что большинство версий Ubuntu поддерживается в течение 18 месяцев после релиза. Например, 10.10 в течение 18 месяцев, и не будет получать обновления безопасности, такие как новые версии Firefox. Существует несколько версий Ubuntu, которые ЛЦ (долгосрочная поддержка) релизы, которые будут поддерживаться в течение трех или пяти лет.

На графике ниже (из Википедии) показывает поддержку различных версий. Желтый стандартный 18 месяцев. Оранжевый-расширенная поддержка на рабочем столе. (Красный-это расширенная поддержка только на сервере, это не включает в Firefox.) Suport

+860
Kingdom Identity 3 сент. 2011 г., 14:07:35

Я хоть и новый Ubuntu один показатель для 13.04 будет означать хорошие новости, но правда в том, что я думаю, что это не так хорошо, как один я использую в 12.10. Есть ли какой-то способ снять его и просто держать я все готова использовать? Сейчас у меня есть два идентичных облачных иконки в systray и это просто излишним.

+849
Kumaralingam 1 февр. 2010 г., 3:11:20

Бодхи Linux является минималистический дистрибутив, основанный на Ubuntu, которая только требует 300 МГц процессор и 128 МБ оперативной памяти - и он основан на Ubuntu 12.04. Выглядит слишком большой. Я использую его даже на моем ноуте с i5.

+842
gpothan 18 мая 2010 г., 18:04:50

Что ВМ вы используете? Если я правильно помню, вы, как правило, дают ОС какой-то виртуальный раздел при установки на виртуальную машину (VirtualBox и обычно просит перед установкой). Вероятно, ваш раздел с Ubuntu слишком мал для установки операционной системы. Я предполагаю, что у вас достаточно места на жестком диске для установки?

+823
Geoff Howard 15 мая 2012 г., 10:16:57
  1. Правильный синтаксис для указания адреса серверов в файл/etc/сети/интерфейсов является

    слово iface eth0 в инет статический
    ...
     ДНС-серверы 1.1.1.1 2.2.2.2
    
  2. В файле/etc/сети/интерфейсов, как указано в вашем вопросе вы назвали интерфейса этно , а не через eth0.

  3. Можно опустить сетевых опцию в файл/etc/сети/интерфейсов. Это больше не требуются или не используются.

После редактирования файла/etc/сети/интерфейсов выполните следующие действия, чтобы активировать изменения.

 команду sudo ifdown eth0 в
 команду sudo ifup eth0 в
+800
adam2012 29 окт. 2015 г., 9:31:08

Откройте Dash и поиск "нвидиа". Программа "от Nvidia X сервер" должен появиться. Откройте его и вы сможете установить разрешение от этой программы.

Ваш английский превосходен, не будучи носителем языка, кстати!

+794
Santos 5 июл. 2011 г., 16:58:01

Да, вы можете! Просто загрузиться через Live CD или USB, нажмите кнопку Установить на странице, после чего нажмите кнопку "Продолжить" (при необходимости можно скачать обновления при установке). В "тип установки" выберите "Обновление с Ubuntu 11.10 для Ubuntu 12.04 ЛТС" и нажмите кнопку Установить сейчас... вы сделали. Это позволит сохранить ваши старые файлы и т. д. При обновлении операционной системы.

+788
qowmeq 4 мая 2010 г., 23:03:09

Она открывается в другом браузере, как хром или Опера? Если это так, то проблема может быть в браузере Firefox или другие браузеры. Однако, это не общая проблема (например, jquery.com отлично работает для меня), но что-то неправильно в вашей конкретной установки. Одна вещь, чтобы попробовать создать новый профиль в Firefox и попробуйте зайти на сайт, чтобы переопределить любые настройки, которые вы сделали.

Если он не открывается в любых браузерах (вы даже можете попробовать wget из командной строки и посмотреть, если это может принести от jquery.com), то проблема находится на более низком уровне. Вы можете иметь некоторые правила iptables блокирование доступа к jquery.com (проверить с iptables -л, опять же это не то универсального в Ubuntu, это должно быть что-то вы настроены конкретно).

Наконец, там может быть что-то блокирует доступ вне компьютера (кэширующий прокси-сервер или брандмауэр, или даже задача маршрутизации между вами и jquery.com). В такой сети проблемы могут быть диагностированы с помощью команды traceroute jquery.com, чтобы увидеть, как далеко идти пакеты до остановки.

+780
vorobushek 14 нояб. 2018 г., 9:47:09

Это возможно, но это сложная, и тема здесь.

Вы можете найти учебник по программе VirtualBox сайте. Подводя итог необходимо:

  • Настроить виртуальную машину, чтобы быть как можно ближе к реальному оборудованию, специально MAC-адреса сетевых карт virtualiced
  • Скопируйте ДМИ информацию от BIOS на вашей виртуальной машине.
  • Установка Windows 7 на реальном оборудовании
  • Создать ВДК для RAW диск.
  • Создать нового пользователя с полным доступом к диску для запуска ВМ
  • Сделать некоторые вуду для восстановления Windows MBR-диск.
  • Установить дополнения гостевой, надеюсь, что они не противоречат настоящим водителем.
+717
user219297 15 авг. 2017 г., 3:51:43

одна вещь, которая всегда сводила меня с ума-это нужно сделать

 МВ файл1 ТМП
 МВ файл2 файл1
 МВ ТМП файл2

в Одер, чтобы поменять 2 файлов.

чем вы пользуетесь, чтобы поменять 2 файла? Есть ли стандартный сценарий для подкачав? что-то вроде ув файл1 файл2 будет приятно

+588
willp 27 июл. 2013 г., 23:48:39

Вы будете иметь, чтобы позволить ему выполнить по крайней мере один раз. для fsck является законным здоровье-проверить, и это "правильно" делать.

тем не менее, если вы не давая ему закончить, и он все еще работает каждый раз, когда вы перезагрузите компьютер, проверьте умный результатов в Дисковой утилите приложение (Диск может быть плохо), или поменяйте частоту проверки диска командой:

команду sudo tune2fs -с 50 в /dev/sda1, поскольку

будьте уверены, чтобы изменить устройство на имя вашего устройства, и не стесняйтесь регулировать количество, а также.

+567
jkb 16 янв. 2014 г., 6:40:35

Хотя Spotify показывает в индикатора-звук просто отлично (контролируя его работу) с помощью мультимедийных клавиш на клавиатуре ничего не делает.

Когда я открываю в Rhythmbox они не могли контролировать там музыка, и настройки клавиатуры выглядят ОК.

+532
duckcubbie 2 мая 2015 г., 7:23:53

Это может быть вызвано расширения. Попробуйте отключить все расширения и посмотреть, если это работает лучше.

+481
deckardk 14 сент. 2014 г., 3:24:50

У меня есть небольшая проблема обновления моего Ubuntu. Я не обновлять его, а я сегодня попробовал. Проблема в том, что я пытался 3 раза, и там такая же проблема. Проблема говорит что-то вроде этого: "ошибка при проверке пакетов. Не удалось проверить подлинность некоторых пакетов. Это может быть из-за временной проблемы сети. Вы можете попробовать позже. Ниже у вас есть список пакетов, которые не удалось проверить подлинность".

И есть много пакетов.

+472
Christopher rojas 15 янв. 2015 г., 22:13:06

Количество сбойных секторов, что утилита отображает складывается из отраслей, которые:

  1. Перераспределяются
  2. Невозвратными
  3. В ожидании

При чтении сектора не удается, он будет помещен в список ожидающих. В следующий раз, когда вы пытаетесь писать на секторе будем стараться, чтобы там писать, а если писать не получается, он будет перераспределять сектора из запасной бассейн, если есть запчасти в секторах. При написании работали, то количество сбойных секторов будет идти вниз. Это может произойти потому, что сектор был омлет, но физически нормально. Часто это приведет к внезапной потере питания в середине записи.

+413
JerseyFog 10 июн. 2018 г., 5:24:38

Лучший способ создать ярлыки это: просто нажмите сочетание клавиш Ctrl+АЛТ+т на клавиатуре, чтобы открыть терминал. Когда она открывается, выполните команды ниже.

суда apt-получить установку гном-панель

После завершения установки, введите следующую команду в командной строке.

гном-рабочий стол-элемент-правка-создать-новый ~/рабочий стол

После ввода команды выше, Windows откроет новые свойства ярлыка:

enter image description here

Просто выберите тип, введите имя,команду, и любые комментарии, что вам нравится, и нажмите кнопку ОК. Пример показан ниже:

enter image description here

enter image description here

+391
Dipali 12 июн. 2012 г., 11:59:44

Да, Аппорт игнорирует sigquit и да, это ММО ошибка.

Я сообщил об этом в https://bugs.launchpad.net/ubuntu/+источник/Аппорт/+баг/1153662 с патч, и фикс был выпущен.

+389
Rush 1 сент. 2013 г., 15:20:32

Я думаю, ты ищешь что-то подобное приложение: "уби: неофициальный Ubuntu в одном приложении для Maemo 5 и другие Qt с поддержкой платформ"

Ссылка: http://ubi.garage.maemo.org/

+302
Jack King 30 окт. 2010 г., 6:22:44

Я установил индикатор-сборных грузов 0.2-0ubuntu1 из центра программного обеспечения. (Он очень похож на индикатор панели GNOME показывает памяти и графики процессора)

Когда я нажимаю на панели Unity, которая показывает мало графической памяти, он говорит ;

Мэм :1.451 ГБ кэш: 2.581. Это также представлено в цветовой графике.

Однако, когда я загрузить Системный монитор, поменять на плоский 0.

Это нормально, или может ли быть ошибка в системном мониторе или панели индикатора?

+204
Anna Nagy 5 сент. 2016 г., 7:35:34

Вы будете иметь, чтобы создать пакет и отправить этот пакет для включения в Ubuntu.

В Убунту сайте разработчика есть страница, создание пакетов для новых программ с вся эта информация в хороший обзор. Он объясняет:

  • Стартовый пакет
  • Сборка пакета
  • Отправка на включение

Также рассмотреть вопрос о представлении этого в Debian как в Ubuntu (и намного больше распределение) основано на том, что вы достигнете еще больше зрителей.

+165
LInkshot 15 окт. 2013 г., 6:24:36

Вы могли бы попробовать это:

Попробуйте сбросить настройки пульса.

Используя терминал="приложения->стандартные->терминал"

РМ -Р ~/.пульс ~/.asound* ~/.пульс-печенье 
судо РМ файл /etc/asound.конф

Перезагрузка и игнорировать ошибки никакой нет такого файла или каталога

+146
ahmed samir 9 сент. 2017 г., 4:13:36

Тип файла: XHTML будет проблема. Нормально, если Скопировать текст гиперссылки из LibreOffice в другую WYSIWYG редактор все приходит с проблемой в CSS нет. Я старался и работал.

+73
apone 22 окт. 2010 г., 14:22:11

Как отметил nelaar, ".поэтому" файлы, как правило, общий двоичных библиотек. Попробуйте сделать "readelf выступает -на станции.так", это может дать вам некоторую информацию о том, что файл содержит (если это действительно файл библиотеки).

+58
Johnolithic 31 окт. 2018 г., 11:21:12
+54
Markus Dicks 25 авг. 2016 г., 3:36:20

Показать вопросы с тегом